A Cross-Site Scripting (XSS) vulnerability has been identified in the WordPress Locatoraid Store Locator Plugin. This vulnerability could allow an attacker to inject malicious scripts into the affected website, potentially compromising the security of the website and its visitors.
This vulnerability was discovered and responsibly reported by Dao Xuan Hieu.
The vulnerability is an XSS vulnerability that occurs in the lpr-search.php file. The vulnerability allows an attacker to inject malicious scripts into the affected website by specifying a specially crafted URL.
The vulnerability has a CVSS 3.1 score of 7.1, which is considered to be high. This means that the vulnerability is likely to be exploited and could have a significant impact on the affected system.
The vulnerability affects all versions of the Locatoraid Store Locator Plugin prior to 3.9.24.
An attacker who successfully exploits this vulnerability could inject malicious scripts into the affected website, such as:
- Other HTML payloads
These malicious scripts could then be executed by visitors to the website, potentially leading to a variety of security risks, such as:
- Phishing attacks
- Malware infections
- Identity theft
Users of the Locatoraid Store Locator Plugin are strongly advised to update to the latest available version (at least 3.9.24). This vulnerability has been fixed in version 3.9.24.