A critical cross-site scripting (XSS) vulnerability has been discovered in the Variation Swatches for WooCommerce plugin for WordPress. This security flaw allows attackers to inject malicious scripts into web pages, posing significant risks to WordPress security and website integrity. The vulnerability, reported by Phd, stems from a failure to properly sanitize user input in the plugin, enabling attackers to inject harmful scripts into the plugin’s input fields. By sending a specially crafted request, attackers can exploit the vulnerability, executing the malicious script when the web page is accessed by unsuspecting users.
The XSS vulnerability in the Variation Swatches for WooCommerce plugin allows attackers to inject malicious scripts into web pages displayed to victims. These scripts can be executed by the victim’s browser, potentially leading to the theft of sensitive data, malware installation, or system disruption.
The severity of this vulnerability is critical, with a CVSS 3.1 score of 9.8. This indicates a high likelihood of exploitation and the potential to significantly impact system confidentiality, integrity, and availability.
Versions of the Variation Swatches for WooCommerce plugin prior to 2.3.8 are vulnerable to this exploit.
Exploiting this vulnerability empowers attackers to inject malicious scripts into web pages viewed by victims. When accessed, these scripts execute, enabling the attacker to steal sensitive data, install malware, or disrupt system operations.
To ensure WordPress security and protect against malware, users of the Variation Swatches for WooCommerce plugin are strongly advised to update to version 2.3.8 or higher immediately.