A Sensitive Data Exposure vulnerability has been discovered in the WordPress WPvivid Backup and Migration plugin. This vulnerability could allow an attacker to gain access to sensitive data, such as database credentials and backups.

This vulnerability was discovered and reported by Unknown.

The Sensitive Data Exposure vulnerability is caused by a lack of input validation in the plugin’s code. This allows an attacker to inject malicious code into the website, which is then executed.

The vulnerability has been fixed in version 0.9.92 of the WordPress WPvivid Backup and Migration plugin. Users who are running an older version of the plugin should update to the latest version as soon as possible.


The vulnerability has a CVSS 3.1 score of 8.0, which is considered to be high severity. This means that the vulnerability is moderately likely to be exploited and could have a significant impact on the affected system.

Affected Versions

All versions of the WordPress WPvivid Backup and Migration plugin prior to 0.9.92.


A Sensitive Data Exposure vulnerability in a WordPress plugin poses several significant risks:

  • Data Exposure: The vulnerability can lead to the exposure of sensitive data, including confidential user information and security credentials.
  • Privacy Risks: Sensitive user data might be at risk, leading to potential privacy breaches and legal repercussions.
  • Credibility Damage: A security breach could tarnish your website’s credibility and erode user trust.


Given the critical nature of this vulnerability, we recommend the following actions:

  1. Update the Plugin: Swiftly update the WPvivid Backup and Migration Plugin to version 0.9.92 or the latest available version.
  2. Security Audits: Regularly conduct security audits on the website to identify and address potential vulnerabilities proactively.
  3. Data Encryption: Implement robust data encryption measures to safeguard sensitive information, both at rest and in transit.