A Cross-Site Scripting (XSS) vulnerability has been identified in the WordPress Stagtools Plugin. This vulnerability could allow an attacker to inject malicious scripts into the affected website, potentially compromising the security of the website and its visitors.

This vulnerability was discovered and responsibly reported by Le Ngoc Anh.

The vulnerability is an XSS vulnerability that occurs in the stagtools.php file. The vulnerability allows an attacker to inject malicious scripts into the affected website by exploiting a flaw in the way that the plugin handles user input.


The vulnerability has a CVSS 3.1 score of 7.1, which is considered to be high. This means that the vulnerability is likely to be exploited and could have a significant impact on the affected system.

Affected Versions:

The vulnerability affects all versions of the Stagtools Plugin prior to 2.3.8.


An attacker who successfully exploits this vulnerability could inject malicious scripts into the affected website, such as:

  • Redirects
  • Advertisements
  • Other HTML payloads

These malicious scripts could then be executed by visitors to the website, potentially leading to a variety of security risks, such as:

  • Phishing attacks
  • Malware infections
  • Identity theft


In light of the seriousness of this vulnerability, Users of the Stagtools Plugin strongly recommend the following actions:

  • Immediate Update: Ensure that WordPress Stagtools Plugin is updated to at least version 2.3.8, or the latest available version. This update contains vital security patches to address the XSS vulnerability and enhance overall plugin security.
  • Regular Security Audits: Conduct routine security audits of the WordPress website to identify and address vulnerabilities promptly.