A Cross-Site Scripting (XSS) vulnerability has been identified in the WordPress AcyMailing SMTP Newsletter Plugin. This vulnerability could allow an attacker to inject malicious scripts into the affected website, potentially compromising the security of the website and its visitors.
This vulnerability was discovered and responsibly reported by Rafshanzani Suhada.
The vulnerability is an XSS vulnerability that occurs in the acymailing-smtp.php file. The vulnerability allows an attacker to inject malicious scripts into the affected website by exploiting a flaw in the way that the plugin handles user input.
The vulnerability has a CVSS 3.1 score of 7.1, which is considered to be high. This means that the vulnerability is likely to be exploited and could have a significant impact on the affected system.
The vulnerability affects all versions of the AcyMailing SMTP Newsletter Plugin prior to 8.6.3.
An attacker who successfully exploits this vulnerability could inject malicious scripts into the affected website, such as:
- Other HTML payloads
These malicious scripts could then be executed by visitors to the website, potentially leading to a variety of security risks, such as:
- Phishing attacks
- Malware infections
- Identity theft
Considering the critical nature of this vulnerability, users can take the following actions to reduce the risk of exploitation:
- Update Without Delay: Users of the AcyMailing SMTP Newsletter Plugin are strongly advised to update to the latest available version (at least 8.6.3). This vulnerability has been fixed in version 8.6.3.
- Regular Security Audits: Implement routine security audits for the WordPress website to detect and address vulnerabilities promptly.